package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)at$`)
var str = `a black cat
a white cat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}