re = /\d{2}(0[1-9]|1[0-2]|5[1-9]|6[0-2])(0[1-9]|1[0-9]|2[0-9]|3[0-1])\/?\d{3,4}/mi
str = '6110136219
755309/6100
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end