package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^6]|6[^0]|60[^0])`)
var str = `123
623
603
600`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}