use strict;
my $str = '👨f‍🍳o ';
my $regex = qr/(?:&#)(([\da-fx]|;&#)+);/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";