import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$status\\['[^']+'\\][^']*'\\K(?:[^']|'')+";
final String string = "$status['Совершенно_новое'] = 'Brand_new<<'' New''>>New' \n"
+ "$status['Совершенно_новое'] = 'Brand_new<br>New'\n"
+ "$status['2'] = \"Brand_new<<' New'>>New\" ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}