const regex = /\$\$((?:(?!\$\$).)+)\$\$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\$((?:(?!\\$\\$).)+)\\$\\$', 'gm')
const str = `aaa \$\$123\$\$ c\$ ddd
aaa \$\$123\$\$ c\$ \$\$ddd\$\$
aaa \$\$12\$3\$\$ c\$ \$\$d\$dd\$\$`;
const subst = `<a1>$1</a1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);