re = /^(?!.* .*)(?:[a-z0-9][a-z0-9-]{0,61}[a-z0-9]\.)+[a-z0-9][a-z0-9-]{0,61}[a-z0-9]$/m
str = 'google.com
abc.co.in
goo gle.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end