using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"example\.com\/page\/(?!thing).*";
string input = @"example.com/p/stuff/...
example.com/page/thing/...
example.com/page/stuff/...
example.com/page/other-stuff/...";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}