import re
regex = re.compile(r"PLUS(?:(?!SC).){29}(SC)", flags=re.MULTILINE)
test_str = ("PLUS This is a AC and this is an SC too\n"
"PLUS This is a SC and this is an SC too")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")