$re = '/^(?![^\S\r\n]*import ).*\b(?:lecture\*|event)/m';
$str = 'import test.event
test.event
test.lecture*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);