re = /<tag-1>.*?<\/tag-1>/
str = '<p>You will find below reports for customer <b>[CustomerName]</b> dated <b>[ReportdDate]</b></p>
<tag-1>
<h3>Title1</h3>
<table>
<thead id="t01">
<tr>
<th align=\'center\' width=\'80\'>Order Nr</th>
<th align=\'left\' width=\'400\'>Planning date</th>
<th align=\'left\' width=\'200\'>Info</th>
<th align=\'center\' width=\'200\'>Site Name</th>
</tr>
</thead>
<tbody>
[TableTodo]
</tbody>
</table>
</tag-1>
<tag-2>
<h3>Title2</h3>
<table>
<thead id="t01">
<tr>
<th align=\'center\' width=\'80\'>Order Nr</th>
<th align=\'left\' width=\'100\'>Date</th>
<th align=\'left\' width=\'400\'>Info</th>
<th align=\'center\' width=\'200\'>Site Name</th>
</tr>
</thead>
<tbody>
[TableTodo]
</tbody>
</table>
</tag-2>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result