#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\$\w+)\[(\w*[a-z]\w*)\]"
Local $sString = "<?php" & @CRLF & _
"$options[$list[_capture_me]][]=array($list[_captureme],$list[_capture_me]);" & @CRLF & _
" $option_names[$list[_capture_me]]=$list[_captureme];" & @CRLF & _
" $product_name=$list[capture_me];" & @CRLF & _
"$product_name=$list[0];" & @CRLF & _
"$product_name=$list[DONTCAPTUREME];" & @CRLF & _
"$product_name=$list[CapTureMe];" & @CRLF & _
"$product_name=$list[CapTurEME];" & @CRLF & _
" $actionKey = $get[DONT_CAPTURE_ME];" & @CRLF & _
"" & @CRLF & _
" if(array_key_exists(DONT_CAPTURE_ME,$get)) {" & @CRLF & _
" $actionKey = $get[DONT_CAPTURE_ME];" & @CRLF & _
" if(array_key_exists($actionKey,$this->arrPageActions)){" & @CRLF & _
" $this->arrAllTemplatesAndAttributes[$templateID][captureme]['Capture_Me'][$res[option_values_id]] = $res[DONT_CAPTURE_ME];" & @CRLF & _
"$old_faq_id.="$result[faq_id]&"; " & @CRLF & _
" $result['toc']="<b><a href=$PHP_SELF#$result[faq_id]>$result['question']</a></b>";}" & @CRLF & _
" $result['toc']="<b><a href=$PHP_SELF#$result[faq_id]>$result[QUESTION]</a></b>";}" & @CRLF & _
"$login_groups_id = $check_admin[login_groups_id];" & @CRLF & _
"?>" & @CRLF & _
"" & @CRLF & _
"<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->" & @CRLF & _
"" & @CRLF & _
"function check_input(field_name, field_size, message) {" & @CRLF & _
" if ($elements[capture_me] && (form.elements[dont_capture].type != "hidden") && $form.elements[capture_me]) {" & @CRLF & _
" var field_value = form.elements[dontcapure].value;" & @CRLF & _
" var field_value = $form.elements[capureme].value;" & @CRLF & _
"" & @CRLF & _
" if (field_value == '' || field_value.length < field_size) {" & @CRLF & _
" error_message = error_message + "* " + message + "\n";" & @CRLF & _
" error = true;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}"
Local $sSubst = "$1['$2']"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)