using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%(?:(?![0-9a-fA-F]{2}))";
string input = @"%f
%fg
%gf
%gg
%
%%
%-
%
%f4
%F3
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}