# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^.]+\.(?=[^.]+$)"
test_str = ("// hash starts with number\n"
"/css/app.style.7fef363d5a8c4ef2458c.css\n"
"/css/app.bundle.7fef363d5a8c4ef2458c.css\n"
"/css/app.chunk.7fef363d5a8c4ef2458c.css\n"
"/css/app.7fef363d5a8c4ef2458c.css\n"
"/css/loading-animation.7fef363d5a8c4ef2458c.css\n\n"
"// hash starts with letter\n"
"/css/app.style.b3bcb606396f0c96623a.css\n"
"/css/app.bundle.b3bcb606396f0c96623a.css\n"
"/css/app.chunk.b3bcb606396f0c96623a.css\n"
"/css/app.b3bcb606396f0c96623a.css\n\n"
"// no preceeding dot separated name before the hash\n"
"/css/loading-animation.b3bcb606396f0c96623a.css\n"
"/css/app.b3bcb606396f0c96623a.js")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.