// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\S+\d\.\d+").unwrap();
let string = "Internet Uplink FON 41.79.9.117 : Successful
Microtik 194.201.253.246 : Successful
Rooftop Switch 213.150.96.166: Successful
TELNET TEST
telnet mail.kenyaweb.com 25 : Connected to mail.kenyaweb.com. Escape character is '^]'. 220 mail.kenyaweb.com ESMTP Postfix
telnet mail.kenyaweb.com 110: Connected to mail.kenyaweb.com. Escape character is '^]'. +OK POP3 ready
MAIL SERVERS
mail.kenyaweb.com 194.201.253.165 : Successful
Relay.kenyaweb.com 194.201.253.124 : Successful
pop.kenyaweb.com 194.201.253.11 : Successful
hosting.kenyaweb.com 194.201.253.132 : Successful
WEB SERVERS
Web server 1 194.201.253.70 : Successful
Web server 2 194.201.253.8 : Successful
Web Server 3 194.201.253.5 : Successful
sungura.kenyaweb.com 192.64.112.132: Successful
DNS
Linux.form-net.com 194.201.253.105 : Successful
ns200.kenyaweb.com 194.201.253.186 : Successful
ns201.kenyaweb.com 194.201.253.189 : Successful
ns203.kenyaweb.com 63.250.47.221 : Successful
BROWSE TEST
www.kenyaweb.com http://www.kenyaweb.com : Successful
www.yahoo.com http://www.yahoo.com : Successful
www.google.com http://www.google.com : Successful
MAIL TEST
Mail.Kenyaweb to yahoo : Received
Mail.Kenyaweb to gmail : Received
Yahoo to Mail.Kenyaweb : Received
Gmail to Mail.Kenyaweb : Received";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}