re = /^(?:https?:\/\/)?(?:(?:www|gaming)\.)?youtube\.com\/(?:channel\/|(?:user\/)?)([a-z\-_0-9]+)\/?(?:[\?#]?.*)/i
str = 'https://www.youtube.com/user/Vsauce'
# Print the match result
str.match(re) do |match|
puts match.to_s
end