$re = '/&(?![^[]*])/m';
$str = 'gotcha & symbol [but not that & one [even that & one] and not this & one] but this is & ok';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);