re = /^(?=[^A-Z\s]*[A-Z])(?=[^a-z\s]*[a-z])(?=[^\d\s]*\d)(?=\w*[\W_])\S{8,}$/m
str = 'foobAr 1
foobAr_1
foobAr$123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end