import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<query_date>\\d{4}-\\d{2}-\\d{2}T\\d{2}:\\d{2}:\\d{2}Z UTC) \\[ db=(?P<db>\\w+) LOG:(?P<query_text>[\\w|\\W]*?;)";
final String string = "'2021-06-23T08:02:08Z UTC [ db=dev LOG: BEGIN;\n"
+ "'2021-06-23T08:02:08Z UTC [ db=dev LOG: SET datestyle TO ISO;\n"
+ "'2021-06-23T08:02:08Z UTC [ db=dev LOG: SET TRANSACTION READ ONLY;\n"
+ "'2021-06-23T08:02:08Z UTC [ db=dev LOG: SET STATEMENT_TIMEOUT\n"
+ " TO 300000;\n"
+ "'2021-06-23T08:02:08Z UTC [ LOG: /* hash: 8d9692aa66628f2ea5b0b9de8e4ea59b */\n\n"
+ "SELECT action,\n"
+ " status,\n"
+ " COUNT(*) AS num_req\n"
+ "FROM stl_datashare_changes_consumer\n"
+ "WHERE actiontime > getdate() - INTERVAL '1 day'\n"
+ "GROUP BY 1,2;\n"
+ "'2021-06-23T08:02:08Z UTC [ LOG: SELECT pg_catalog.stll_datashare_changes_consumer.action AS action, pg_catalog.stll_datashare_changes_consumer.status AS status, COUNT(*) AS num_req FROM pg_catalog.stll_datashare_changes_consumer WHERE pg_catalog.stll_datashare_changes_consumer.actiontime > getdate() - interval '1 day'::Interval GROUP BY 1, 2;\n"
+ "'2021-06-23T08:02:08Z UTC [ LOG: COMMIT;\n"
+ "'2021-06-23T08:02:08Z UTC [ LOG: SET query_group to ''\n"
+ "'2021-06-23T08:02:22Z UTC [ LOG: SELECT 1\n"
+ "'2021-06-23T08:02:30Z UTC [ LOG: /* hash: 64f5dca78e917617f51632257854cb2f */\n"
+ "WITH per_commit_info AS\n"
+ "(\n"
+ " SELECT date_trunc('day', startwork) AS day,\n"
+ " c.xid,\n"
+ " SUM(num_metadata_blocks_retained) AS sum_retained,\n"
+ " SUM(total_metadata_blocks) AS sum_total,\n"
+ " AVG(num_metadata_blocks_retained) AS avg_retained,\n"
+ " AVG(total_metadata_blocks) AS avg_total\n"
+ " FROM stl_commit_stats c,\n"
+ " stl_commit_internal_stats i\n"
+ " WHERE c.xid = i.xid\n"
+ " < ...even more sql >;\n"
+ "'2021-06-23T08:02:30Z UTC [ LOG: SELECT per_commit_info.day AS day, COUNT(*) AS commits,\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}