$re = '/where((?!where).)*?]\s?/m';
$str = 'where that and that do that where [this = 1] group by 1,2,3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);