$re = '/para(?!chute)\w*(,|$)/m';
$str = 'parachute,parakeet,parapet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);