$re = '/\d+(=?\.(\d+(=?\.(\d+)*)*)*)*/m';
$str = 'v3.0.2+g19e47ee
v3.0+g19e47ee
v3+g19e47ee
Version 1.0.1
WARNING:: NEVER EDIT/DELETE THIS SECTION';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);