re = /\/(|en-US|en-GB|en-AU|fr-CA|en-CA|es-MX|tr-TR)*\/*(legal-platform)\/+/m
str = '/legal-platform/sdcdscs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end