$re = '/(?<=track\/)(\w*)(?=\??)/m';
$str = 'spotify.com/track/1HYcYZCOpaLjg51qUg8ilA?si=Nf5w1q9MTKu3zG_CJ83RWA
spotify.com/track/1HYcYZCOpaLjg51qUg8ilA
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);