$re = '/^[0-9-]+$/';
$str = '123-123-123-123254235';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);