$re = '/\d(\d)\1{2}/';
$str = '555-1000
555-9000
555-9123
555-9999
555-9090
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);