import Foundation
let pattern = #"\b((?:ri)?comprat)[aeio]\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"ricomprate uno comprato comprata due comprate ricomprate tre ricomprato comprati"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1+"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)