$re = '/^[0-9]{1,2}[dD]([468]|1[02]|20)\s?[+-]\s?[0-9]{1,2}[dD]([468]|1[02]|20)$/m';
$str = '5D20+5d12
12D22 +3d20
5d12+5d81
5d10 +5d4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);