# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\((?:[^()]++|(?R))*\)|,"
test_str = ("SELECT Name AS [Object Name], Switch([Type]=5,'Query',[Type]=-32768,'Form',[Type]=6,'Table') AS [Object Type], Switch([Type]=5,1,[Type]=-32768,2,[Type] In (1,4,6),6) AS [Object Type ID], Left(Name,4) as Prefix, LTrim(RTrim(Mid([Name],5,30))) as Suffix\n\n"
"SELECT \"Amy's code is righteous.\", left(\"abc\",1), right('source code',4), \"Bill's code has been righteous too.\"\n\n"
"----------\n\n"
"End goal is to replace all commas in SQL SELECT clause with comma+linefeed but ignore commas inside parenthesis (which may be nested).\n\n"
"\\((?:[^()]++|(?R))*\\)\n\n"
"This expression will find all of the nested parentheis using recursion. I want to do one of these two options:\n"
" a) Replace all commas in the matched groups with the pipe \"|\" character, \n"
" then with two simple StrReplace() calls: replace all commas with comma+linefeed, then replace all | with comma.\n"
"OR\n"
" b) Select all text that is not in the matched group and replace commas with comma+linefeed.\n\n"
"I'm using AutoHotkey and the RegExReplace() function.")
subst = "|$0|"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.