# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=card setlment).*([-|+]\d+[.]\d+)"
test_str = ("\n"
" cb-lt \n"
" For 2020-12-08/12/3/3\n"
" dec tue \n"
" \n\n"
"Name ID shoping company shop gold Net Fees Net\n"
" card card card card \n"
"------------------------------------------------------------------------------------------------------------------------\n"
"smantha 5 78952 .00 366410.00 0.00 30800.00 -586.65 -471656.65\n"
"kamnthi 7 99999.00 0.00 0.00 0.00 0.00 -5800.00\n"
"nimali 8 8888888.00 587960.15 0.00 741985.00 -784.35 509027.80\n\n"
"card setlment 4568153.37 2325802.00 3298.00 175882.41 -3049.24 -577589\n\n"
"1\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.