package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(.*\)`)
var str = `ABC ( DEF (GHI) JKL ) MNO`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}