$re = '/^(?!\d+$)(?:[1-9]\d*)?[dD]?[1-9]\d*(?:\s*[-+\/*]\s*(?:[1-9]\d*)?[dD]?[1-9]\d*)*$/m';
$str = 'd20
2D12+ 4 - 2
12d4-2d6+7 + d8
7 + 1d12
would all be valid. Whereas expressions like these:
-2d6+4
-d8 - 5
12
2d0 + 5
1d6 + 0d2 - 1
0d6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);