re = /(\?(?<=\?).*(?=\?))/
str = 'localhost.com/en_ar/body?products_type=235&treatment=132?product_type=235&treatment=132&__from_store=en_bh
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end