package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z]\s[0-9]`)
var str = `a 1
b
2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}