$re = '/\bmyzol\s+[^{]*{[^{}]*\bmrzulf\b[^{}]*}/m';
$str = 'gvt
hjk hlkjhf c
myzol 123gbhj {
test
check myself/mrzulf/.com
}
myzol 123gbhj {
test
check myself/mrzulf/.com
}
myzol 1fde3gbhj {
test
check myself/check/.com
}
myzol 12ecehj {
test
check myself/mrzulf/.com
}
myzol 1evehj {
test
check myself/check/.com
}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;