$re = '/(?<=\/)[\w-+=\s]{7,}(?![.])(?!\.)(?=\/|\n)/m';
$str = '/test/ajs1d5haFkajs1dhasdd2as345sdAS3+Ddas9
/test/akKd9Ja3/ajs1d5haFkajs1ddasd623ha5sdAS3Ddas9=/30
/test/akKd9Ja3/Example-ASDAdddasd-108174.js
/test/akKd9Ja3-ASj83asj-dask92qwe_ke
';
$subst = "<random>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;