#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)3([0-9]){2}.?([0-9]){6}[0-9]?"
Local $sString = "6x7 456 78993 45528 8382 837372 82 128 8282 82 828282 28 8282635372892 838 " & @CRLF & _
"Lorem ipsum dolor 335-5555555 sit amet, consectetur adipisci5555555555 elit, sed eiusmod tempor incidunt ut labore et dolore magna aliqua." & @CRLF & _
"" & @CRLF & _
"Ut enim ad minim veniam, quis nostrum exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur. 3835555555 Quis aute iure reprehenderit in voluptate 555/555555velit esse cillum dolore eu fugiat nulla pariatur. 43434734 343 3 464 56 5 65 6 5 757 676" & @CRLF & _
"" & @CRLF & _
"Excepteur sint obcaecat cupiditat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum. Lorem ipsum dolor sit amet, consec 234 546 367 2789 tetur adipisci elit,347/5555555 sed eiusm 565437 od tempor incidunt ut labore et dolore magna aliqua. Ut enim ad minim" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Ut enim ad minim 555-555555veniam, quis nostrum exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur. Quis aute iure r328 5555555 eprehenderit in volup6767676767 6767676767tate 555 555555velit esse cillum dolore eu fugiat nulla pariatur." & @CRLF & _
"" & @CRLF & _
"Excepteur sint obcae67676767676767676cat cupidita34567893 t non proident, sunt in culpa qui officia deserunt mollit anim id est laborum. 388.555555 Lorem ipsum dolor sit amet, consectetur adipisci elit, sed eiusmod tempor incidunt ut labore et dolore magna a6767676767 32252525 353535 5353535liqua. Ut enim ad minim"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")