#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\.)\b\$?[1-9]\d*\.\d{2}\b(?!\.\d)"
Local $sString = "12.34 56.78.90.12 34.56" & @CRLF & _
"" & @CRLF & _
"123.45. 345.67. 912.23" & @CRLF & _
"" & @CRLF & _
"$98.76" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")