re = /[\\]author*|[{]((?:[^{}]*|[{][^{}]*[}])*)[}]/m
str = '\\author{
\\small
}
\\maketitle'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end