$re = '/\d$/m';
$str = 'Винни: 1
Пятачок: 2
Слонопотам: 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);