# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Representatives:\s+(?<rep_name>.*)\(.*\)\s+((?<rep2_name>.*)?\s+\()?"
test_str = ("----------------------------------------------\n"
"SESSION SUMMARY\n"
"----------------------------------------------\n"
"Representatives:\n"
" Amoz Abraham (ID: 23)\n"
" Jose Sandoval (ID: 25)\n\n"
"Customer Name: [Pinned] SOUTHLAWN02\n"
"Customer's Public IP: 174.110.83.140:56969\n"
"Customer's Private IP: 10.5.65.90\n\n"
"Session Start Time: 2020-05-15 17:03:22 US/Pacific\n"
"Session End Time: 2020-05-15 17:11:37 US/Pacific\n"
"Duration: 00:08:15\n"
"# Files Transferred: 0\n"
"# Files Moved: 0\n"
"# Files Deleted: 0\n\n\n"
"----------------------------------------------\n"
"SYSTEM INFORMATION RETRIEVED\n"
"----------------------------------------------\n"
"## General ## \n"
" \n"
"Version: Windows 10 Pro x64 \n"
"Computer Name: SOUTHLAWN02 \n"
"System BIOS: \n"
"Processor 1 Info: Intel(R) Core(TM) i5-9500 CPU @ 3.00GHz \n"
"Processor 2 Info: Intel(R) Core(TM) i5-9500 CPU @ 3.00GHz \n"
"Processor 3 Info: Intel(R) Core(TM) i5-9500 CPU @ 3.00GHz \n"
"Processor 4 Info: Intel(R) Core(TM) i5-9500 CPU @ 3.00GHz \n"
"Processor 5 Info: Intel(R) Core(TM) i5-9500 CPU @ 3.00GHz \n"
"Processor 6 Info: Intel(R) Core(TM) i5-9500 CPU @ 3.00GHz \n"
"Default Browser: Google Chrome \n"
"Default Browser Version: 81.0.4044.138 \n"
"Default Browser Location: C:\\Program Files (x86)\\Google\\Chrome\\Application\\chrome.exe \n"
"Windows® Directory: C:\\Windows \n"
"System Directory: C:\\Windows\\system32 \n"
"Time Zone: Eastern Daylight Time \n"
" ")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.