$re = '~ ^
(?:
\d{2}
(?:
/
(?:
\d{2}
(?:
/
(?:
\d{2}
(?:
[ ]
(?:
\d{2}
(?:
:
(?:
\d{2}
(?:
:
(?:
\d{2}
)?
)?
)?
)?
)?
)?
)?
)?
)?
)?
)?
~mx';
$str = '11/10/25 17:22:31
X11/10/25 17:22:31
11/10/25 X17:22:31
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);