import Foundation
let pattern = #"(?:(?<=@import\s*(['"]|url\()\s*)((?:\S|\\\1)+)\s*(?:\1|\))\s*\)?\s?(.*?);)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
# Drupal core/tests/Drupal/Tests/Core/Asset/css_test_files/css_input_with_import.css
@import "import1.css";
@import "import2.css";
@import url("http://example.com/style.css");
@import url("//example.com/style.css");
# Examples from https://developer.mozilla.org/en-US/docs/Web/CSS/%40import
@import url("finep;rint.css") print;
@import url("bluish.;css") projection, tv;
@import 'cust;om.css';
@import url("chrome://communi;cator/skin/");
@import "common.css" screen, projection;
@import url('landscape.css') screen and (orientation:landscape);
# Examples using htmlentities
@import 'https://fonts.googleapis.com/css?family=Sedgwick+Ave+Display&subset=latin-ext';
@import "https://fonts.googleapis.com/css?family=Sedgwick+Ave+Display&subset=latin-ext" ;
@import url("https://fonts.googleapis.com/css?family=Sedgwick+Ave+Display&subset=latin-ext");
@import url("https://fonts.googleapis.com/css?family=Sedgwick+Ave+Display&subset=latin-ext") tv;
@import url("https://fonts.googleapis.com/css?family=Sedgwick+Ave+Display&subset=latin-ext") only screen and (max-width:639px) and (orientation: portrait);
# Additional
@import "cu'st;om.css";
@import "cu\"st;om.css";
@import "cu\22st;om.css";
@import 'cus\'t;om.css';
@import 'cus\27t;om.css' ;
@import 'cus(t;om.css' ;
@import 'cus)t;om.css';
@import 'cus(t);om.css';
@import url( " http://user:pass@example.com/c'u(s)t;o\"m.css " ) ;
@import url( ' http://user:pass@example.com/c"u(s)t;o\'m.css ' ) ;
@import url( http://user:pass@example.com/c\'u\(s\)t;om.css ) ;
# Inline
@import "cu'st;om.css"; @import "cu\"st;om.css"; .my-class { display: block; }
@import "cu'st;om.css";@import url( " http://user:pass@example.com/c'u(s)t;o\"m.css " ) ;.some-class { color: rgba(0, 0, 0); }@import url( http://user:pass@example.com/c\'u\(s\)t;om.css ) ;.some-class { color: rgba(0, 0, 0); }
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)