import Foundation
let pattern = #"(?i)(?<ipv6>(?:[\da-f]{0,4}:){1,7}(?:(?<ipv4>(?:(?:25[0-5]|2[0-4]\d|1?\d\d?)\.){3}(?:25[0-5]|2[0-4]\d|1?\d\d?))|[\da-f]{0,4}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2001:db8:3333:4444:5555:6666:7777:8888
2001:db8:3333:4444:CCCC:DDDD:EEEE:FFFF
2001:0db8:0001:0000:0000:0ab9:C0A8:
fffe:3465:efab:23fe:2235:6565
2001:0000:6dcd:8c74:::ac32:6a1
2345:0425:2CA1:::5673:23b5
2001:db8:1::ab9:C0A8:102
2001:db8::1234:5678
FF02:0:0:0:0:0:0:2
fdf8:f53b:82e4::53
fe80::200:5aee:feaa:20a2
2001:0000:4136:e378:
8000:63bf:3fff:fdd2
2001:db8::
::1234:5678
2000::
2001:db8:a0b:12f0::1
2001:4:112:cd:65a:753:0:a1
2001:0002:6c::430
2001:5::
fe08::7:8
2001:10:240:ab::a
2002:cb0a:3cdd:1::1
2001:db8:8:4::2
ff01:0:0:0:0:0:0:2
1:2:3:4:5:6:7:8
1::3:4:5:6:7:8
1::4:5:6:7:8
1:2:3::5:6:7:8
1::7:8
1:2:3:4:5::7:8
1:2:3:4:5::8
::2:3:4:5:6:7:8
::8
::
::1
::ffff:192.0.2.47
::255.255.255.255
::ffff:255.255.255.255
::ffff:0:255.255.255.255
2001:db8:3:4::192.0.2.33
64:ff9b::192.0.2.33
2001:db8:3333:4444:5555:6666:1.2.3.4
24a6:57:c:36cf:0000:5efe:109.205.140.116
::11.22.33.44
::10.0.0.3
2001:db8::123.123.123.123
::ffff:10.0.0.3
::1234:5678:91.123.4.56
::1234:5678:1.2.3.4
2001:db8::1234:5678:5.6.7.8
2001:db8:3:4:5::192.0.2.33
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)