import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Exception:)(?!.*\\1)(?<exception>[^,]+),\\s+Job";
final String string = "Exception:100 : *** Error 3006 Logons are disabled., Job=ABC\n"
+ "Exception:XYZ API has failed. Exception: RDBMS error 2801: Duplicate unique prime key error, Job=ABC\n"
+ "Exception:100 : RDBMS error 2640: Specified table either does not exist in DEX or is moved to another map., Job=ABC";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}