$re = '/([^\n]+\n?)/m';
$str = '1vjsjvnjs134
2fds
3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);