$re = '/^[+]? *[0-9][0-9 ]*$/m';
$str = '+13434343434
+ 3
343434
3434';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);