re = /^5(\d\d)\1{3}$/m
str = '261616161
561616161
555555555
532323232
512312312
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end