import re
regex = re.compile(r"href=\"(\w[^\"]+\/pdf4v\/\w[^\"]+)", flags=re.MULTILINE)
test_str = ("<ul>\n"
"<li><a href=\"#\" id=\"fav\" onclick=\"return favoritesadd(8094,'fav.png','removefav.png');\"><img id=\"fav8094\" src=\"fav.png\" alt=\"\" border=\"0\" /> <span id=\"fav8094\">ADD TO WISHLIST</span></a></li>\n"
"<li class=\"sixcol right\"><a href=\"https://documents.domain.com/content/updates/year18/jv/folder01/pdf/pdf8094.zip?exp=1567791065&hsh=5a49e7d4828603beddbfb058a1535f5e&dl=att&filename=pdf-00008094-16.pdf\" class=\"tcenter\"><img src=\"pdf.png\" class=\"icon\" align=\"left\" />16<br /><span class=\"small\">download pdf</span></a></li>\n"
"<li class=\"sixcol\"><a href=\"https://documents.domain.com/content/updates/year18/jv/folder01/pdf4v/pdf4v8094.zip?exp=1567791065&hsh=246a7702296f7db363ecaa1746a8815a&dl=att&filename=pdf-00008094-40.pdf\" class=\"tcenter\"><img src=\"pdf.png\" class=\"icon\" align=\"left\" />40<br /><span class=\"small\">download pdf</span></a></li>\n"
"<div class=\"clear\"></div>\n"
"<li><a href=\"/details.php?id=8094&num=1&ss=1\" onclick=\"$.open();return false;\"><img src=\"/images/details.png\" class=\"center\" />Details</a></li>\n"
"</ul>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")