#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=((.+?)\2+))"
Local $sString = "rghtyjdfrtdfdf56r" & @CRLF & _
"rtafafafaf" & @CRLF & _
"ccccc" & @CRLF & _
"abc" & @CRLF & _
"aababcc" & @CRLF & _
"ababcc" & @CRLF & _
"abcabcabab" & @CRLF & _
"aabbff"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")